Apr 09

How to Protect Your Mac from Flashback Malware

According to the TechMediaNetwork a few days ago, a malware called “Mac Flashback” has infected nearly 60 million Apple Mac. So, what should we do in this case? How to protect your Mac from Flashback malware? It is reported that Mac users need to do three things to protect themselves against such malicious software. Following are three things you need to do:

Firstly, check your Mac to know if it has been infected by the Flashback. Social networking news site Mashable has created a script to help users do this, users can visit the Mashable website to check the according to those instructions.

If the script finds the Mac has been infected (one or two places in Mac OS X file system may be infected), then it is a little complicated to clear this malware, you must enter the Terminal application, and then clear this Flashback malware in accordance with the detailed steps from F-Secure of Finnish security company.

Secondly, you can update your OS X by using latest security patches that Apple provides. Recently, Apple has released OS X 10.6 Snow Leopard and OS X Lion patch. In addition, it has upgraded OS X Lion patch. on April 5th. However, if you are using the OS X 10.5 Leopard Mac version which based on the PowerPC chip, then Apple will no longer care about you.

Thirdly, take a deep breath, and then say to yourself: “Steve Jobs has passed away, my Mac is not infected with the virus.” And then install a reliable anti-virus product. You have to take action immediately without any delay.

Both the antivirus program bundled in OS X 10.7 Lion and the upcoming Gatekeeper from OS X 10.8 Mountain Lion cannot protect your Mac at all.

For Mac users, you can not only visit TopTenReviews to view the products with evaluation, but also log in the Sophos from British Security Company to download the free Mac antivirus software.

In addition, there are two things you must do:

1. Close the Java runtime engine, if you do not use it.

As the tool to run the network applications and perform other tasks, Java has too many flaws. Due to this reason, it’s unnecessary for you to open Java runtime engine unless you really need to use it. You can open Java parameters from Mac OS X and don’t check all the options, then restart.

Unfortunately, Photoshop, Illustrator, and InDesign in Adobe Creative Suite applications require the Java environment to run. In this case, you have to trust Apple again, although Apple is obvious on slow-moving in helping Mac users. Two months ago, Windows and Linux version patches had been introduced to repair the Java flaws that Mac Flashback used.

2. If you are still using PowerPC Mac, it is time to make a change.

There are still millions of PowerPC Mac still in use and well-run, the latest production date is in 2006. However, Apple no longer provides support or security patches. Thus, Apple hopes you to upgrade your Mac OS so that you can find the way to protect your Mac from all kinds of virus.